Задать вопрос

Надо написать программу на Паскале, без массивов. Дано натуральное число. Определить, сколько раз у этого числа встречается минимальная цифра. (Например, при вводе числа 2618319, на экране должно быть "2").

+3
Ответы (1)
  1. 11 апреля, 20:11
    0
    program zz1;

    var n, min, i, kol, b, c:integer; / /задаем переменные

    begin

    write ('введите заданное число '); / /вводим заданное число

    read (n);

    b:=n; / /запоминаем заданное число в другой переменной

    min:=9; / /задаем начальное значение для минимальной цифры

    while n>0 do / /в этом цикле находим минимальную цифру в числе

    begin

    c:=n mod 10;

    n:=n div 10;

    if c
    end;

    while b>0 do//в этом цикле находим количество минимальных цифр в числе

    begin

    c:=b mod 10;

    b:=b div 10;

    if c=min then kol:=kol+1;

    end;

    write ('количество минимальных цифр = ', kol); / /выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Надо написать программу на Паскале, без массивов. Дано натуральное число. Определить, сколько раз у этого числа встречается минимальная ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Требовалось написать программу, при выполнении которой с клавиатуры вводится натуральное число, не превосходящее 10^8, и выводится его первая цифра.
Ответы (1)
Бит - это: a) Логический элемент b) Минимальная единица информации, принимающая значение 0 или 1 c) Минимальная единица информации, принимающая значение 0 d) Минимальная единица информации, принимающая значение 1
Ответы (1)
Напишите программу которая выводит на экран слово "женский" при вводе символа Ж и словa " мужской" при вводе символа М
Ответы (1)
написать программу на языке паскаля 1) Дано натуральное число. Определить является ли оно чётным 2) дано натуральное число. Определить оканчивается ли оно цифрой 7.
Ответы (1)
Автоматическое устройство имеет 2 кнопки и экран. При включении на экране загорается число 0. При нажатии на одну кнопку число на экране удваивается (вместо х появляется 2 х).
Ответы (1)