Задать вопрос

Найти в массиве в (10) сумму элементов под четными номерами

+2
Ответы (1)
  1. 5 августа, 16:18
    0
    Program summ;

    var

    B: array [1 ... 100] of integer;

    n, i, sum: integer;

    begin

    writeln ('Введите количество элементов массива');

    readln (n);

    for i:=1 to n do B[i]:=random (100);

    for i:=1 to n do

    if i mod 2=0 then sum:=sum+B[i];

    writeln ('Сумма элементов с четными индексами равна: ', sum);

    readln;

    end.

    В условии используем функцию выделения остатка от деления mod. Если остаток от деления на 2 равен 0, значит число четное.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Найти в массиве в (10) сумму элементов под четными номерами ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. В массиве B[5,6], значения элементов находятся в интервале [-25,30]. Подсчитать количество элементов, значение которых кратно 4. 2. В массиве C[6,10], значения элементов находятся в интервале [10,30], найти сумму элементов в 1 строке. 3.
Ответы (1)
Дан массив целых чисел. Нумерация элементов начинается с 0. Выведите все элементы массива с четными номерами. Формат входных данныхСначала задано число N - количество элементов в массиве, N100. Далее через пробел записаны N чисел - элементы массива.
Ответы (1)
Создать одномерный массив с помощью генератора случайных чисел, содержащий целые числа из диапазона от - 20 до + 80. К элементам с четными номерами прибавить А, а из элементов с нечетными номерами вычесть В. А и В вводятся с клавиатуры.
Ответы (1)
Дан массив из 10 элементов найти сумму элементов с четными номерами. Написать программу на языке программирования
Ответы (1)
Составить программы для паскаля для следующих задач: 1. В массиве из 10 элементов подсчитать количество нечетных элементов 2. Вычислить сумму квадратов элементов, больших 2. Массив состоит из 5 элементов действительного типа. 3. Даны два массива.
Ответы (1)