Задать вопрос

Даны два целых числа A и В. Выведите все числа от A до B включительно, в порядке возрастания, если A < B, или в порядке убывания в противном случае

+3
Ответы (1)
  1. 26 октября, 11:36
    0
    program zz1;

    var a, b, i:integer; / / задаем переменные целого типа

    begin

    write (' введите первое число '); / / вводим с клавиатуры первое число

    read (a);

    write (' введите второе число '); / / вводим с клавиатуры второе число

    read (b);

    if a < b / / проверяем условие, если первое число меньше второго, то

    then for i:=a to b do write (i, ' ') / / выводим ответ по возрастанию

    else for i:=a downto b do write (i, ' '); / / иначе, выводим ответ по убыванию

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Даны два целых числа A и В. Выведите все числа от A до B включительно, в порядке возрастания, если A < B, или в порядке убывания в ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Для 4 произвольных чисел, введенные с клавиатуры, выведите на экран соответствующие результаты. если разностьпервых двух чисел превышает четвертое, то выведите все четыре числа без изменения.
Ответы (1)
Обозначим символом Z бит, определяющий факт равенства результата R нулю, а символом N - бит, фиксирующий отрицательность R: Z = 1 при R = 0, иZ=0 в противном случае; N = 1 при ЯR О, и 0 в противном случае.
Ответы (1)
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)
Даны два целых числа A и B (при этом A ≤ B). Выведите все числа от A до B включительно.
Ответы (1)
Напишите программу в паскаль для решения следующей задачи: для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты.
Ответы (1)