Задать вопрос

В массиве хранится информация о среднедневной температуре ноября (в С°) 1. Опишите данный массив. 2. Заполните массив случайными целыми числами из отрезка [-3; 7]. 3. Выведите элементы данного массива в строчку через пробел. 4. Выведите даты дней, когда температура была выше нуля. 5. Подсчитайте количество дней с нулевой температурой. 6. Выведите самую низкую температуру месяца. 7. Найдите среднюю температуру ноября.

+2
Ответы (1)
  1. 21 мая, 11:52
    0
    program zz1;

    const n = 30; / /задаем количество элементов в массиве

    var i, min, k, s:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / записываем в массив числа случайным образом

    m[i]:=random (11) - 3;

    for i:=1 to n do / /выводим массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    for i:=1 to n do

    if m[i]>0 then writeln (i,'-го ноября было выше нуля ');

    for i:=1 to n do

    if m[i]=0 then k:=k + 1;

    writeln (' Количество дней с нулевой температурой = ', k);

    min:=100;

    for i:=1 to n do

    if m[i]
    writeln (' Самая низкая температура = ', min);

    for i:=1 to n do

    s:=s + m[i];

    writeln (' Средняя температура = ', s/30);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «В массиве хранится информация о среднедневной температуре ноября (в С°) 1. Опишите данный массив. 2. Заполните массив случайными целыми ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Дан массив целых чисел. Нумерация элементов начинается с 0. Выведите все элементы массива с четными номерами. Формат входных данныхСначала задано число N - количество элементов в массиве, N100. Далее через пробел записаны N чисел - элементы массива.
Ответы (1)
For i:=1 to N do Begin write ('C[', i,']='); readln (C[i]); end * Приведенный фрагмент программы, предназчен для 1 вывода массива в столбец 2 вывода массива в строку 3 формирования массива случайными числами 4 ввода массива с клавиатуры For i:=
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
Сначала задано число N - количество элементов в массиве. Далее через пробел записаны N чисел - элементы массива. Необходимо вывести все четные элементы массива (то есть те элементы, которые являются четными числами).
Ответы (1)