Задать вопрос

Составить программу находящую максимальный и минимальный элемент масива и меняющий их местами

+3
Ответы (1)
  1. 20 августа, 07:40
    0
    program zz1;

    const n = 14; / / задаем количество элементов в массиве

    var i, max1, min, k1, k2:integer;

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / записываем в массив числа случайным образом

    m[i]:=random (201) - 60;

    for i:=1 to n do / /выводим массив на экран

    write (m[i],' ');

    writeln;

    max1:=0;

    for i:=1 to n do

    if m[i]>max1 then begin max1:=m[i]; k1:=i; end;

    min:=1000000;

    for i:=1 to n do

    if m[i] < min then begin min:=m[i]; k2:=i; end;

    swap (m[k1], m[k2]);

    for i:=1 to n do

    write (m[i],' ');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить программу находящую максимальный и минимальный элемент масива и меняющий их местами ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Дана матрица размером M * N. В каждой строке матрицы найти минимальный элемент и максимальный из найденного. 2) дана матрица размерами N * N. Поменять местами столбец с максимальным и столбец содержащий минимальное количество нулевых элементов.
Ответы (1)
Дан массив B (n*m). Элементы массива ввести в программе. Поменять местами максимальный и минимальный элемент. Паскаль двумерный массив пример присвоения элементов массива в программе : b: array[1 ... n, 1 ...
Ответы (1)
Дан одномерный массив A[N]. Удвоить минимальный элемент массива и уменьшить в два раза максимальный элемент массива
Ответы (1)
Уменьшить максимальный элемент массива на величину индекса, а минимальный элемент увеличить на значение среднего арифметического по всему массиву
Ответы (1)
Составьте программу, которая заполняет массив a[1 ... 100] случайными целыми числами в диапозоне от 1 до 100, затем меняет местами максимальный и минимальный элементы.
Ответы (1)