Задать вопрос
31 июля, 02:28

дан массив из 6 натуральных чисел: {4,6,2,5,1,3}. Над элементами массива разрешено проделывать только одну операцию: менять местами любые два расположенных рядом элемента. Какое минимальное количество раз необходимо выполнить эту операцию, для того, чтобы массив оказался отсортирован по убыванию? Укажите числа

+5
Ответы (1)
  1. 31 июля, 05:34
    0
    1 раз меняем числа 6 и 4: {6,4,2,5,1,3}

    2 раз меняем числа 2 и 5: {6,4,5,2,1,3}

    3 раз меняем числа 4 и 5: {6,5,4,2,1,3}

    4 раз меняем числа 1 и 3: {6,5,4,2,3,1}

    5 раз меняем числа 2 и 3: {6,5,4,3,2,1}

    Ответ: минимальное количество раз, которое необходимо выполнить операцию обмена расположенных рядом элементов, для того, чтобы массив оказался отсортирован по убыванию 5 раз.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «дан массив из 6 натуральных чисел: {4,6,2,5,1,3}. Над элементами массива разрешено проделывать только одну операцию: менять местами любые ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Дан массив 1 2 3 4 5 6 7 8 7 0 - 8 - 4 2 16 - 10 2 А Определите: А) размерность массива; Б) значение элемента А[3]; В) значение максимального элемента массива; Г) индекс первого отрицательного элемента массива;
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
Дан массив, состоящий из целых чисел. Напишите программу, которая подсчитает количество элементов массива, больших предыдущего (элемента с предыдущим номером). Входные данные Сначала задано число N - количество элементов в массиве (1N10000).
Ответы (1)
1. Составить программу, которая вводит с клавиатура массив из 5 целых чисел и выводит на экран значение четвертого элемента массива. 2. Дан массив из 10 элементов, заполненный удвоенными значениями индексов элементов массива.
Ответы (1)
For i:=1 to N do Begin write ('C[', i,']='); readln (C[i]); end * Приведенный фрагмент программы, предназчен для 1 вывода массива в столбец 2 вывода массива в строку 3 формирования массива случайными числами 4 ввода массива с клавиатуры For i:=
Ответы (1)