Задать вопрос

Дан массив, состоящий из целых чисел. Напишите программу, которая подсчитает количество элементов массива, больших предыдущего (элемента с предыдущим номером). Входные данные Сначала задано число N - количество элементов в массиве (1N10000). Далее через пробел записаны N чисел - элементы массива. Массив состоит из целых чисел. Выходные данные Необходимо вывести единственное число - количество элементов массива, больших предыдущего.

+4
Ответы (1)
  1. 24 мая, 16:09
    0
    program massiv;

    var a: array[1 ... 100] of integer;

    i, n, col: integer;

    begin

    writeln ('Введите количество элементов в массиве');

    readln (n);

    writeln ('Заполните массив с клавиатуры');

    for i : = 1 to n do readln (a[i]);

    writeln ('Подсчёт элементов, больших предыдущего');

    for i : = 2 to n do if a[i] > a[i-1] then col : = col + 1;

    writeln ('Количество элементов, больших предыдущего', col);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дан массив, состоящий из целых чисел. Напишите программу, которая подсчитает количество элементов массива, больших предыдущего (элемента с ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Вводится массив, состоящий из целых чисел. Найти наибольшее среди них. Входные данные Сначала задано число N - количество элементов в массиве (1N35). Далее через пробел записаны N чисел - элементы массива. Массив состоит из целых чисел.
Ответы (1)
Дан массив, состоящий из целых чисел. Напишите программу, которая в данном массиве определит количество элементов, у которых два соседних и, при этом, оба соседних элемента меньше данного.
Ответы (1)
Дан массив целых чисел. Нумерация элементов начинается с 0. Выведите все элементы массива с четными номерами. Формат входных данныхСначала задано число N - количество элементов в массиве, N100. Далее через пробел записаны N чисел - элементы массива.
Ответы (1)
Сначала задано число N - количество элементов в массиве. Далее через пробел записаны N чисел - элементы массива. Необходимо вывести все четные элементы массива (то есть те элементы, которые являются четными числами).
Ответы (1)
Напишите программу, которая сортирует элементы массива по возрастанию последней цифры десятичной записи чисел. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)