Войти
Задать вопрос
Иван Ковалев
Информатика
14 декабря, 11:19
Даны натуральные числа А до В (В
+2
Ответы (
1
)
Александр Коновалов
14 декабря, 12:45
0
program zz1;
var a, b, r, i:integer; / / задаем переменные целого типа
begin
write (' введите первое заданное число '); / / вводим с клавиатуры первое число
read (a);
write (' введите второе заданное число обязательно меньше первого '); / / вводим с клавиатуры второе число
read (b);
for i:=b to a do / / организуем цикл, в котором переберем все числа от b до a
r:=r + i; / / вычисляем сумму чисел от b до a, прибавляя к сумме очередное число из цикла
write (' сумма чисел от ', b,' до ', a,' = ', r); / / выводим ответ
end.
Комментировать
Жалоба
Ссылка
Знаешь ответ на этот вопрос?
Отправить
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆
«Даны натуральные числа А до В (В ...»
по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Даны натуральные числа n и m. Составьте программу, которая вычисляет сумму последних m цифр числа n.
Ответы (1)
Даны натуральные числа m, n. Получить все кратные им числа, меньшие m*n. сделать на паскале)
Ответы (1)
Даны натуральные числа n и k. Найти ответ примера 1k + 2k + ... + nk. В Паскале
Ответы (1)
Даны натуральные числа от 35 до 87. Найти и напечатать те из них, которые делятся на 5 или на 7
Ответы (2)
Даны натуральные числа от 20 до 50. напечатать те из них, которые делятся на 3, но не делятся на 5. Программа на Pascal
Ответы (1)
Нужен ответ
Из данных слов Выпиши имена существительные сильный зима, найти, дерево, рисовать, красивый, воробей, река, ручной, решать, подснежник, показаться.
Нет ответа
В санатории привезли апельсины мандарины и лимоны апельсины составляет пять четырнадцатых всех фруктов мандарины восемь 21-й, а лимоны остальные 99 кг сколько килограммов фруктов привезли в санаторий
Нет ответа
Расположите числа 5,28; - 1,634; - 1,34; - 1, (3); 2,3 (4) и 2, (34) в порядке убывания
Нет ответа
сравнить природные условия финикии древнего египта и индии
Нет ответа
Расстояние между двумя пунктами 40 км. Из одного из них в другой одновременно въезжают автобус и велосипедист. Скорость автобуса 50 км в час, велосипедиста 10 км в час.
Нет ответа
Главная
»
Информатика
» Даны натуральные числа А до В (В
Войти
Регистрация
Забыл пароль