Задать вопрос
20 мая, 21:32

Написать программу, которая проверяет, представляют ли элементы введенного с клавиатуры массива возрастающую последовательность

+3
Ответы (1)
  1. const n = 5;

    var a : array of real;

    k, i : integer;

    x : real;

    begin

    cls;

    setlength (a, n);

    for i : = 0 to n-1 do begin

    write ('a[', i,'] = ');

    readln (a[ i ]);

    if (i > 0) and (k = 0) and (x > a[ i ]) then k : = 1;

    x : = a[ i ];

    end;

    if k = 1 then writeln ('Элементы данного массива не представляют собой возрастающую последовательность.')

    else writeln ('Элементы данного массива представляют собой возрастающую последовательность.');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу, которая проверяет, представляют ли элементы введенного с клавиатуры массива возрастающую последовательность ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
For i:=1 to N do Begin write ('C[', i,']='); readln (C[i]); end * Приведенный фрагмент программы, предназчен для 1 вывода массива в столбец 2 вывода массива в строку 3 формирования массива случайными числами 4 ввода массива с клавиатуры For i:=
Ответы (1)
Напишите программу, которая сортирует элементы массива по возрастанию последней цифры десятичной записи чисел. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
Составить программу, которая по номеру месяца, введенного с клавиатуры, выводит количество дней в нем.
Ответы (1)
Составить программу, которая позволяет вводить с клавиатуры элементы массива a[1 ... 10] и числа k1 и k2, а затем выводит на экран в одну строку элементы массива с индексами от k1 до k2
Ответы (1)