Задать вопрос

Составить программу в Паскаль: Дано число меньше 16 определить - сколько единичных битов содержит двоичная запись этого числа.

+5
Ответы (1)
  1. 10 января, 06:45
    0
    program zz1;

    var a, b, n:integer; / / задаем переменные целого типа

    begin

    write (' введите натуральное число < 16 '); / / вводим с клавиатуры число

    read (n);

    while n > 1 do / / организуем цикл, пока введенное число больше чем единица

    begin

    a:=n mod 2; / / получаем двоичную цифру

    if a = 1 then b:=b + 1; / / проверяем ее, если единица, то считаем

    n:=n div 2; / / уменьшаем заданное число

    if n = 1 then b:=b + 1;

    end;

    write (' количество единичных битов в двоичной записи числа = ', b); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить программу в Паскаль: Дано число меньше 16 определить - сколько единичных битов содержит двоичная запись этого числа. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Звуковая плата производит двоичное кодирование аналогового звукового сигна - ла. Какое количество информации необходимо для кодирования каждого из 65536 возможных уровней громкости сигнала? 1. 65536 битов 2. 256 битов 3. 16 битов 4. 8 битов 2.
Ответы (1)
1) Сколько значащих нулей в двоичной записи десятичного числа 503? 2). Для каждого из перечисленных ниже десятичных чисел построили двоичную запись. Укажите число, двоичная запись которого содержит наибольшее количество значащих нулей.
Ответы (1)
Заполните пропуски. 1) 1 байт = битов 2) 128 битов = байтов 3) 32 байта = битов 4) 1 Кбайт = байтов 5) 1,5 Кбайт = байтов 6) 2048 байтов = Кбайт 7) 81 920 битов = Кбайт 8) 2 Мбайт = Кбайт 9) 1,5 Мбайт = байтов
Ответы (1)
Переведите данные числа в десятичную системы счисления двоичная 1111010 двоичная 1001,101 восьмеричная 54,2 шестнадцатеричная В3,2
Ответы (1)
1) Некоторый алфавит содержит 512 символов. Сообщение содержит 22 символа. Определите информационный объём сообщения. 1) 1280 битов 2) 70 битов 3) 24,75 байтов 4) 70 байтов.
Ответы (1)