Задать вопрос
13 января, 14:47

Написать программу в паскале: Вычислить сумму 2^2+2^3+2^4 + ... + 2^10. Операцию возведения в квадрат не использовать.

+1
Ответы (1)
  1. 13 января, 18:08
    0
    program zz1;

    var s, i, v:integer; / / задаем переменные целого типа

    begin

    s:=0; / / задаем начальное значение для переменной суммы

    v:=2; / / задаем начальное значение для переменной степени числа

    for i:=2 to 10 do / / организуем цикл, в котором переберем все степени от двух до десяти

    begin

    v:=v * 2; / / получаем следующее слагаемое числа, умножая его каждый раз на два

    s:=s + v; / / добавляем полученное слагаемое в сумму

    end;

    writeln (' полученная сумма = ', s); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу в паскале: Вычислить сумму 2^2+2^3+2^4 + ... + 2^10. Операцию возведения в квадрат не использовать. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Даны два различных вещественных числа X и Y. Написать программу, возведения наименьшего из чисел в квадрат, наибольшего - в куб и нахождения среднего арифметического полученных значений. 2.
Ответы (1)
Вычислить сумму c# 1+1/3+1/3^2 + ... + 1/3^8 Операцию возведения в степень не ис - пользовать. c# только цикл
Ответы (1)
В классическом паскале нет функции возведения в степень. Если программисту на паскале все же потребуется возвести число a>0 в степень n, то с помощью какого выражения он может это сделать?
Ответы (1)
Написать программу в паскале! Написать программу при помощи процедуры, которая по известному радиусу возвращает в основную программу значения площади круга и длины окружности.
Ответы (1)
В паскале не предусмотрена операция возведения в степень. Составте программу для расчета степени n вещественного числа a (n - натуральное число).
Ответы (1)