Задать вопрос
28 августа, 06:41

Написать программу в Паскале: В массиве из N действительных чисел, введённых с клавиатуры, найти номер первого отрицательного элемента и выдать на экран этот элемент или сообщение о том, что в массиве отрицательных элементов нет.

+2
Ответы (1)
  1. 28 августа, 08:44
    0
    program zz1;

    var i, n, k:integer; / / задаем переменные целого типа

    m:array [1 ... 1000] of integer;

    begin

    write (' введите заданное число ');

    read (n);

    for i:=1 to n do / / получаем n чисел с клавиатуры и записываем их в массив

    read (m[i]);

    for i:=1 to n do

    if m[i] < 0 / / проверяем условие, если очередной элемент массива отрицательный, то выводим ответ, запоминаем это событие и прерываем цикл

    then begin write (' первый отрицательный элемент = ', m[i]); k:=1; break; end;

    if k = 0 then write (' отрицательных элементов массива нет ');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу в Паскале: В массиве из N действительных чисел, введённых с клавиатуры, найти номер первого отрицательного элемента и ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1. В одномерном массиве из 10 целых чисел вычислить количество отрицательных элементов в каждой десятке элементов. 2. Определить сумму минимального и максимального элементов массива из 20 действительных чисел. 3. Дан массив из 20 целых чисел.
Ответы (1)
1. Дан массив 1 2 3 4 5 6 7 8 7 0 - 8 - 4 2 16 - 10 2 А Определите: А) размерность массива; Б) значение элемента А[3]; В) значение максимального элемента массива; Г) индекс первого отрицательного элемента массива;
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
1. В массиве B[5,6], значения элементов находятся в интервале [-25,30]. Подсчитать количество элементов, значение которых кратно 4. 2. В массиве C[6,10], значения элементов находятся в интервале [10,30], найти сумму элементов в 1 строке. 3.
Ответы (1)