Задать вопрос

Требовалось написать программу, которая получает на входе натуральное число n и выводит число, которое получается из n после удаления всех пятерок, порядок остальных цифр при этом не меняется. Программист торопился и написал программу неверно, найдите неверную строку и исправьте ее. var n, r, t:longint; d:integer; begin readln (n); r:=0; t:=1; while n>0 do begin d:=n mod 10; if d=5 then begin r:=r+d*t; t:=t+1 end; n:=n div 10; end; writeln (t); end.

+4
Ответы (1)
  1. 11 февраля, 13:27
    0
    var n, r, t:longint;

    d:integer;

    begin

    readln (n);

    r:=0;

    t:=1;

    while n>0 do

    begin

    d:=n mod 10;

    if d5 then begin r:=r + d*t; t:=t * 10; end; / / первая ошибка - знак "=" заменил на "", вторая ошибка - в формуле t + 1 заменил на t * 10 для формирования нового числа без пятерок

    n:=n div 10;

    end;

    writeln (r); / / третья ошибка, выводим на экран новое полученное число r

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Требовалось написать программу, которая получает на входе натуральное число n и выводит число, которое получается из n после удаления всех ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике