Задать вопрос
11 февраля, 22:15

Подсчитать количество элементов массива, кратных 3 и больших 50 в массиве А {1 ... 10}

+4
Ответы (1)
  1. 12 февраля, 01:57
    0
    В программе я задаю массив, но этого можно не делать, если далее на основе этого задания не будет других задач. Тогда просто организуется цикл for, водится и проверяется на условие число, если условия выполнено - счетчик прибавляется на 1, но это число никуда не записывается и на следующем шаге забывается. Программа С++:

    #include

    using namespace std;

    int main ()

    {

    int k = 0;

    int mas[10];

    for (int i = 0; i < 10; i++) {

    cin >> mas[i];

    if (mas[i] % 3 = = 0 and mas[i] > 50) k++;

    }

    cout << "Количество элементов массива кратных 3 и больших 50: "<
    }
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Подсчитать количество элементов массива, кратных 3 и больших 50 в массиве А {1 ... 10} ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. В массиве B[5,6], значения элементов находятся в интервале [-25,30]. Подсчитать количество элементов, значение которых кратно 4. 2. В массиве C[6,10], значения элементов находятся в интервале [10,30], найти сумму элементов в 1 строке. 3.
Ответы (1)
Составить программы для паскаля для следующих задач: 1. В массиве из 10 элементов подсчитать количество нечетных элементов 2. Вычислить сумму квадратов элементов, больших 2. Массив состоит из 5 элементов действительного типа. 3. Даны два массива.
Ответы (1)
Дан массив, состоящий из целых чисел. Напишите программу, которая подсчитает количество элементов массива, больших предыдущего (элемента с предыдущим номером). Входные данные Сначала задано число N - количество элементов в массиве (1N10000).
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)