Задать вопрос

Составить алгоритм и программу печати значений функции y:=cos^2x для x=10,9,8,7, ...,1.

+4
Ответы (1)
  1. 10 сентября, 07:12
    0
    program zz1;

    var x, y:real; / / задаем переменные не целого типа

    begin

    x:=10;

    while x > = 1 do / / организуем цикл, в котором переберем все числа от десяти до единицы через единицу

    begin

    y:=sqr (cos (2 * x)); / / вычисляем значение по заданной формуле

    writeln (' для ', x, ' вычисленное значение y = ', y:5:2); / / выводим ответ в столбец в формате пять знаков для всего числа и два знака после точки

    x:=x - 1; / / уменьшаем х на единицу

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить алгоритм и программу печати значений функции y:=cos^2x для x=10,9,8,7, ...,1. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Разработать алгоритм для ввода четырёх целых чисел и вычисление их среднего арифметического. Протестировать алгоритм на исходных данных: - 5,8,-1,9. Линейный алгоритм
Ответы (1)
Запишите алгоритм вычисления для заданного количества суток (tfh) количества часов (Л), минут (т) и секунд (с). Выполните вычисления для заданных значений переменной tfh. Алгоритм: tfh 1 2 1/2 h т с
Ответы (1)
Что такое алгоритм? Зачем люди составляют и исполняют алгоритм. Какими разными способами можно описать способ решения задач? Как называют наглядную модель процесса решения задач? Какой алгоритм можно назвать линейным?
Ответы (1)
Дана цепочка символов СТОП. Какая цепочка символов получится, если к данной цепочке применить описанный алгоритм дважды (т. е. применить алгоритм к данной цепочке, а затем к результату вновь применить алгоритм) ?
Ответы (1)
Разработать алгоритм и составить программу вычисления значений суммы S заданного ряда при различных значениях аргумента Х: во внутреннем цикле для фиксированного значения Х поочередно суммировать члены ряда, пока их абсолютная величина превышает
Ответы (1)