Задать вопрос
28 января, 21:27

1. Напишите программу, которая находит количество чисел, кратных 3, но не кратных 6, в последовательности целых чисел. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести одно число - сумму чисел, кратных 3 и не кратных 6, встречающихся с последовательности. Пример работы программы: Входные данные Выходные данные 12 1 15 30 4 2 0

+4
Ответы (1)
  1. 28 января, 23:21
    0
    program zz1;

    var x, y:integer; / / задаем переменные целого типа

    begin

    read (x);

    if (x mod 3 = 0) and (x mod 6 0) then y:=y + x;

    while x 0 do / / организуем цикл, в котором будем вводить числа последовательности, пока не введем ноль

    begin

    read (x);

    if (x mod 3 = 0) and (x mod 6 0) then y:=y + x; / / проверяем, если число последовательности кратное трем и не кратное шести, то добавляем его в сумму

    end;

    write (' Сумма чисел последовательности кратных трем и не кратных шести = ', y); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1. Напишите программу, которая находит количество чисел, кратных 3, но не кратных 6, в последовательности целых чисел. Программа получает ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы