Задать вопрос

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся на 4. Программа получает на вход натуральные числа через клавиатуру, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: сумму всех чисел, кратных 6 и оканчивающихся на 4

+2
Ответы (1)
  1. 5 мая, 12:19
    0
    program aver;

    var s, n, k : integer;

    begin

    n: = 1; / / значение числа для входа в цикл while

    s: = 0; / / сумма чисел, удовлетворяющих условию

    k: = 0; / /счетчик чисел

    writeln ('Введите серию чисел,');

    writeln ('заканчивая ввод каждого числа нажатием на Enter');

    while (n 0) and (k < 1000) do

    begin

    read (n);

    if n > 30000 then

    begin

    writeln ('Число не должно быть больше 30000');

    read (n);

    end;

    if (n mod 10 = 4) and (n mod 6 = 0) then s: = s + n;

    k: = k + 1;

    end;

    writeln ('сумма = ', s)

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся на 4. Программа ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напишите программу, которая в последовательности натуральных чисел определяет количество трёхзначных чисел, кратных 4.
Ответы (1)
1. Напишите программу, которая находит количество чисел, кратных 3, но не кратных 6, в последовательности целых чисел.
Ответы (1)
Напишите программу, которая в последовательности целых чисел определяет максимальное число. программа получает на вход целые числа, количество введенных чисел неизвестно. последовательность числа заканчивается числом 0.
Ответы (1)
Программа получает на вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается нулем. (a=0 признак окончания ввода, ноль не входит в последовательность).
Ответы (1)
Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих 256.
Ответы (1)