Войти
Задать вопрос
Гость
Информатика
9 июня, 22:11
Найти все делители для заданного числа n. Паскаль
+3
Ответы (
1
)
Мирон Соколов
9 июня, 22:48
0
program zz1;
var n, i, k:integer; / / задаем переменные целого типа
begin
write ('введите заданное число n'); / / вводим с клавиатуры заданное число n
read (n);
for i:=1 to n do / / организуем цикл для перебора всех чисел от единицы до заданного числа
begin
if n mod i = 0 / / проверяем, если число n делится на число i, то считаем его и выводим ответ
then begin k:=k+1; writeln (k,'-ый делитель числа = ', i); end;
end;
end.
Комментировать
Жалоба
Ссылка
Знаешь ответ на этот вопрос?
Отправить
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆
«Найти все делители для заданного числа n. Паскаль ...»
по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Найдите произведение трёх чисел вводимых с клавиатуры при условии, что они больше заданного числа (найти по программе паскаль)
Ответы (1)
Как составить на языке Паскаль программу вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа N? Вообще с Паскалем у меня полный завал! Если знаете как, то напишите! Желательно с объяснениями, буду благодарна!
Ответы (1)
Дан массив целых чисел состоящий из 10 элементов вывести индексы тех элементов значение которых больше заданного числа А (А вводится с клавиатуры) Язык программирования: Паскаль
Ответы (1)
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)
Напишите программу на паскаль авс Найти длину окружности L и площадь круга S заданного радиуса R: L = 2·π·R, S = π·R^2. В качестве значения П использовать 3,14.
Ответы (1)
Нужен ответ
Из данных слов Выпиши имена существительные сильный зима, найти, дерево, рисовать, красивый, воробей, река, ручной, решать, подснежник, показаться.
Нет ответа
В санатории привезли апельсины мандарины и лимоны апельсины составляет пять четырнадцатых всех фруктов мандарины восемь 21-й, а лимоны остальные 99 кг сколько килограммов фруктов привезли в санаторий
Нет ответа
Расположите числа 5,28; - 1,634; - 1,34; - 1, (3); 2,3 (4) и 2, (34) в порядке убывания
Нет ответа
сравнить природные условия финикии древнего египта и индии
Нет ответа
Расстояние между двумя пунктами 40 км. Из одного из них в другой одновременно въезжают автобус и велосипедист. Скорость автобуса 50 км в час, велосипедиста 10 км в час.
Нет ответа
Главная
»
Информатика
» Найти все делители для заданного числа n. Паскаль
Войти
Регистрация
Забыл пароль