Задать вопрос

Паскаль. Вывести на экран числа, кратные К из промежутка [А, В]. А, В, К вводятся.

+3
Ответы (1)
  1. 22 мая, 20:12
    0
    program zz1;

    var a, b, k, i:integer; / / задаем переменные целого типа

    begin

    write (' введите первое число '); / / вводим с клавиатуры первое число

    read (a);

    write (' введите второе число '); / / вводим с клавиатуры второе число

    read (b);

    write (' введите третье число '); / / вводим с клавиатуры третье число

    read (k);

    for i:=a to b do / / организуем цикл, в котором переберем все числа от а до b

    if i mod k = 0 / / проверяем условие кратности

    then writeln (' число от ', a,' до ', b,' кратное ', k, ' = ', i); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Паскаль. Вывести на экран числа, кратные К из промежутка [А, В]. А, В, К вводятся. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Напишите программу ввода чисел а, b с клавиатуры. Если a=b, то вывести на экран сумму a и b, иначе вывести на экран b-a (используя Функцию) Паскаль
Ответы (1)
Вводятся два числа А и В (В>А). Вывести на экран числа, которые делятся на 3, но не делятся на 5 и их количество. (Паскаль)
Ответы (1)