Задать вопрос

Найдите сумму элементов в массиве (3,5; 18.3; 28,5; 1,5; 0,18) Напишите программу на Pascal.

+4
Ответы (1)
  1. 17 сентября, 17:13
    0
    program zz1;

    const mas:array[1 ... 5] of real = (3.5, 18.3, 28.5, 1.5, 0.18); / / задаем размер массива и вводим значения элементов

    var s:real; i:integer; / /задаем переменные

    begin

    for i:=1 to 5 do / / выводим массив на экран в строчку через пробел

    write (mas[i],' ');

    writeln; / / переходим на новую строку для вывода

    for i:=1 to 5 do

    s:=s+mas[i]; / / находим сумму элементов массива

    write ('сумма элементов массива = ', s); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Найдите сумму элементов в массиве (3,5; 18.3; 28,5; 1,5; 0,18) Напишите программу на Pascal. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. В массиве B[5,6], значения элементов находятся в интервале [-25,30]. Подсчитать количество элементов, значение которых кратно 4. 2. В массиве C[6,10], значения элементов находятся в интервале [10,30], найти сумму элементов в 1 строке. 3.
Ответы (1)
В одномерном массиве А, состоящий из N действительных элементов, вычислить : a) сумму отрицательных элементов массива; b) количество элементов, удовлетворяющих условию 7 Pascal
Ответы (1)
Составить программы для паскаля для следующих задач: 1. В массиве из 10 элементов подсчитать количество нечетных элементов 2. Вычислить сумму квадратов элементов, больших 2. Массив состоит из 5 элементов действительного типа. 3. Даны два массива.
Ответы (1)
Cделать программу в Pascal по заданию:"Найти в двумерном массиве сумму массива, сумму элементов по столбцам и среднее арифметическое по строкам"
Ответы (1)
1. В одномерном массиве из 10 целых чисел вычислить количество отрицательных элементов в каждой десятке элементов. 2. Определить сумму минимального и максимального элементов массива из 20 действительных чисел. 3. Дан массив из 20 целых чисел.
Ответы (1)