Задать вопрос

написать программу в pascal: заменить последний элемент массива минимальным (размерность массива=10)

+5
Ответы (1)
  1. 28 мая, 17:18
    0
    program zvvz1;

    const n = 10; / / задаем в массиве количество элементов

    var i, min:integer; / / задаем целого типа переменные

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / записываем числа в массив образом случайным

    m[i]:=random (201) - 60;

    for i:=1 to n do / / выводим на экран массив

    write (m[i],' ');

    writeln; / / для вывода ответа переходим на новую строку

    min:=10000000; / / задаем значение начальное для элемента минимального

    for i:=1 to n do / / цикл организуем, в котором все числа массива переберем

    if m[i] < min then min:=m[i]; / / проверяем, если из массива число меньше минимального, то записываем его в минимальное

    m[n]:=min;

    for i:=1 to n do / / на экран выводим массив

    write (m[i],' ');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «написать программу в pascal: заменить последний элемент массива минимальным (размерность массива=10) ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
1. Дан массив 1 2 3 4 5 6 7 8 7 0 - 8 - 4 2 16 - 10 2 А Определите: А) размерность массива; Б) значение элемента А[3]; В) значение максимального элемента массива; Г) индекс первого отрицательного элемента массива;
Ответы (1)
Найти сумму всех элементов массива целых чисел, которые меньше среднего арифметического элементов массива. Размерность массива-20. Заполнение массива осуществить случайными числами от 150 до 300
Ответы (1)
For i:=1 to N do Begin write ('C[', i,']='); readln (C[i]); end * Приведенный фрагмент программы, предназчен для 1 вывода массива в столбец 2 вывода массива в строку 3 формирования массива случайными числами 4 ввода массива с клавиатуры For i:=
Ответы (1)
Создать два одномерных массива, состоящих из целых чисел. Элементы массива вводятся с клавиатуры. В первом массиве найти номер первого нечетного элемента массива. Во втором массиве найти первый четный элемент массива.
Ответы (1)