Задать вопрос

Вводится число. Напечатать YES, если оно является степенью двойки, NO - иначе. Ввод 1 8 Вывод 1 YES Ввод 2 22 Вывод 2 NO

+1
Ответы (1)
  1. 28 мая, 11:06
    0
    program zz1;

    var n:real; / / задаем переменную нецелого типа

    p:integer; / / задаем переменную целого типа

    begin

    write (' введите натуральное число ');

    read (n); / / вводим с клавиатуры число

    while n>2 do / / организуем цикл пока

    begin

    n:=n / 2; / / делим число пополам

    if (n = 1) or (n = 2) then p:=1; / / проверяем, если в конце цикла получилась двойка или единица, то запоминаем это

    end;

    if p = 1 / / проверяем, если нашлось

    then writeln (' YES ') / / выводим один ответ

    else writeln (' NO '); / / иначе, выводим другой ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Вводится число. Напечатать YES, если оно является степенью двойки, NO - иначе. Ввод 1 8 Вывод 1 YES Ввод 2 22 Вывод 2 NO ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Составить алгоритм сложения двух целых чисел F и Q, вводимых с клавиатуры. Результат сложения записать в виде переменной W. По данному алгоритму написать программу в Паскале. алг сложение цел F, Q, W нач ввод F ввод Q W:=F+Q вывод W кон 2.
Ответы (1)
Соедини стрелками устройства компьютера с их функциями. Процессор Отображение данных на экране Монитор - Ввод текста и чисел Сканер Обработка данных Клавиатура Ввод графических данных Принтер Вывод звуковых данных Наушники Ввод звуковых данных
Ответы (1)
Напечатать "столбиком": а) все целые числа от 20 до 35; б) квадраты всех целых чисел от 10 до b (значение b вводится с клавиатуры; b > (или равно) 10); в) третьи степени всех целых чисел от a до 50 (значение а вводится с клавиатуры; а (или равно) а).
Ответы (1)
Дана непустая последовательность целых чисел, оканчивающаяся нулем (0 является признаком окончания последовательности и в последовательность не входит). Найти и напечатать: 1. Сумму всех чисел, больших Х (значение Х вводится с клавиатуры).
Ответы (1)
C++. С клавиатуры вводится любое цело число, если оно чётное, то вывести число 5 иначе любое другое.
Ответы (1)