Задать вопрос

Составьте программу вычисления суммы квадратов от 1 до 20 используя for i, writeln

+2
Ответы (1)
  1. 7 ноября, 01:42
    0
    Для решения задачи использована циклическая алгоритмическая структура, в частности цикл с параметром (цикл "ДЛЯ"). Он наиболее прост и удобен в организации. Кроме того, по условию задачи заранее известно количество повторений цикла (от 1 до 20), следовательно, в тексте программы он будет реализован с помощью операторов

    for to do.

    Program z1;

    Var i, s:integer;

    begin

    s:=0;

    for i:=1 to 20 do

    s: = s + i*i;

    writeln (s);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте программу вычисления суммы квадратов от 1 до 20 используя for i, writeln ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Имеется условный оператор:if D10 then writeln ('ура!') else writeln ('плохо ...'); Какими операторами его можно заменить? Выберите несколько из 4 вариантов ответа: 1) if D=10 then writeln ('ура!') else writeln ('плохо ...
Ответы (1)
Запиши программу в Паскале для вычисления площади прямоугольника со сторонами c и m. 1) begin writeln ('Введи длину и ширину прямоугольника c и m'); readln (c, m); s:=c*m; writeln ('s=', s); readln; end.
Ответы (1)
Program n_1; Var a, b, x, y: real; Begin Writeln ('Введите a') readln (x); Writeln ('Введите b') readln (b); y:=3*x*x+x-4; While x
Ответы (1)
1. Хозяин хочет оклеить обоями стену длиной b и высотой a метров. У него имеется k рулонов шириной 55 см и длиной 10,5 м.
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)