Задать вопрос
21 марта, 11:38

В паскале ввести n целых чисел и подсчитать произведения четных с помощью repead, while

+3
Ответы (1)
  1. 21 марта, 14:51
    0
    program zz1;

    var n, i, j, p:integer; / /задаем переменные

    begin

    write ('введите n '); / /вводим заданное число

    read (n);

    p:=1; / /задаем начальное значение произведения

    i:=1; / /задаем начальное значение параметра цикла

    while i<=n do

    begin

    read (j); / /вводим число

    if j mod 2 = 0 then p:=p*j; / /проверяем, если число делится на два, то умножаем его на произведение

    i:=i+1; / /увеличиваем параметр цикла

    end;

    if p = 1 then writeln ('четных чисел не было') else writeln ('произведение четных чисел с помощью цикла while = ', p); / /выводим ответ

    p:=1;

    i:=1;

    repeat

    begin

    read (j);

    if j mod 2 = 0 then p:=p*j;

    i:=i+1;

    end;

    until i>n;

    if p = 1 then write ('четных чисел не было') else write ('произведение четных чисел с помощью цикла repeat = ', p);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «В паскале ввести n целых чисел и подсчитать произведения четных с помощью repead, while ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Написать программу. Ввести одномерный массив из целых чисел. Подсчитать во сколько раз сумма четных чисел массива превосходит среднее арифметическое всех чисел массива?
Ответы (1)
1) Найти сумму 1/2+1/4+1/6 ... 1/20 на паскале с помощью while и точно такую же задачу с циклом for2) Возведение степени a в степень n, с помощью while
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Ввести 2 числа используя оператор ввода данных read (). Перед оператором read () обязательно вывести объяснения значения какой переменной надо ввести (Например, writeln ('vvedite a'); ). Ввести их через запятую.
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов2) Дан массив целых чисел.
Ответы (1)