Задать вопрос

Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и подсчет количества введеных чисел. Используйте оператор while. Решить в паскале.

+3
Ответы (1)
  1. 10 марта, 17:58
    0
    var

    x:=1; / / переменная Х - вводимое с клавиатуры число, присваиваем значение 1, чтобы не выйти / /из цикла while на первом шаге

    z : integer; / / счетчик чисел вводимых с клавиатуры

    begin

    while (x0) do

    begin

    readln (x); / / вводим число с клавиатуры

    z:=z+1; / / увеличиваем счетчик введенных чисел на 1

    end; / / переходим на следующую строку только если x=0, иначе возвращаемся к while

    writeln (z); / / выводим на экран количество введенных чисел - переменную z

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и подсчет ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и определение максимального (наибольшего) из введёных чисел. Используйте оператор repeat. Решить в паскале.
Ответы (1)
Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и подсчитать количество введённых положительных и отрицательных чисел.
Ответы (1)
Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется пока не будет введен ноль) и определение максимального (наибольшего) из введенных чисел. И составить блок схему
Ответы (1)
Осуществить ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён 0) и подсчитать их сумму и среднее арифметическое введённых положительных чисел. Использовать оператор repeat.
Ответы (1)
Составить две программы на языке Паскаля с помощью операторов цикла До и Пока, которые будут вводить целые числа (до тех пор, пока не будет введен ноль), подсчитывать сумму и среднее арифметическое введеных положительных чисел.
Ответы (1)