Задать вопрос

Составить две программы на языке Паскаля с помощью операторов цикла До и Пока, которые будут вводить целые числа (до тех пор, пока не будет введен ноль), подсчитывать сумму и среднее арифметическое введеных положительных чисел.

+2
Ответы (1)
  1. 18 августа, 01:20
    0
    program zz1;

    var x, y, k:integer; / / задаем переменные целого типа

    begin

    read (x);

    while x 0 do / / организуем цикл, в котором будем вводить числа последовательности, пока не введем ноль

    begin

    y:=y + x; / / считаем сумму

    k:=k + 1; / / считаем количество

    read (x);

    end;

    write (' Сумма чисел последовательности = ', y, ' их количество = ', k); / / выводим ответ

    end.

    program zz1;

    var x, y, k:integer; / / задаем переменные целого типа

    begin

    repeat / / организуем цикл, в котором будем вводить числа последовательности, пока не введем ноль

    read (x);

    y:=y + x; / / считаем сумму

    k:=k + 1; / / считаем количество

    until x=0;

    write (' Сумма чисел последовательности = ', y, ' их количество = ', k - 1); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить две программы на языке Паскаля с помощью операторов цикла До и Пока, которые будут вводить целые числа (до тех пор, пока не будет ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и определение максимального (наибольшего) из введёных чисел. Используйте оператор repeat. Решить в паскале.
Ответы (1)
Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и подсчет количества введеных чисел. Используйте оператор while. Решить в паскале.
Ответы (1)
Осуществить ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён 0) и подсчитать их сумму и среднее арифметическое введённых положительных чисел. Использовать оператор repeat.
Ответы (1)
Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и подсчитать количество введённых положительных и отрицательных чисел.
Ответы (1)
1. Чему будет равна переменная "c" после выполнения этой программы: a : = 28; b : = 7; b : = a div b + b; c : = a mod b + a; Ответ: 2. Чему будет равна переменная "c" после выполнения этой программы: a : = 26; b : = 6; c : = a mod b + b; Ответ: 3.
Ответы (1)