Задать вопрос
5 марта, 04:02

Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и определение максимального (наибольшего) из введёных чисел. Используйте оператор repeat. Решить в паскале.

+1
Ответы (1)
  1. 5 марта, 06:10
    0
    program max_number;

    var n, max: integer;

    begin

    max : = - 1000;

    repeat

    read (n);

    if n > max then max : = n

    until n = 0;

    writeln ('Максимальное число равно = ', max)

    end.

    После каждого ввода в строке

    if n > max then max : = n

    сравнивается значение введенного числа n c зафиксированным максимальным значением в переменной max.

    Условие завершения цикла repeat until n = 0:

    завершить выполнение, если n = 0.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и определение ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и подсчет количества введеных чисел. Используйте оператор while. Решить в паскале.
Ответы (1)
Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется пока не будет введен ноль) и определение максимального (наибольшего) из введенных чисел. И составить блок схему
Ответы (1)
Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и подсчитать количество введённых положительных и отрицательных чисел.
Ответы (1)
Осуществить ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён 0) и подсчитать их сумму и среднее арифметическое введённых положительных чисел. Использовать оператор repeat.
Ответы (1)
Составить две программы на языке Паскаля с помощью операторов цикла До и Пока, которые будут вводить целые числа (до тех пор, пока не будет введен ноль), подсчитывать сумму и среднее арифметическое введеных положительных чисел.
Ответы (1)