Задать вопрос

Дано целое число, определить количество цифр в этом числе.

+2
Ответы (1)
  1. 28 января, 22:10
    0
    program zz1;

    var s, n, k:integer; / / задаем переменные целого типа

    begin

    write (' введите число ');

    read (n); / / вводим с клавиатуры число

    s:=0; / / задаем начальное значение для количества

    while n > 0 do / / организуем цикл, пока в заданном числе есть цифры

    begin

    k:=n mod 10; / / получаем последнюю цифру заданного числа

    s:=s + 1; / / считаем ее

    n:=n div 10; / / отбрасываем ее из числа

    end;

    / / выводим ответ

    writeln (' количество цифр числа = ', s);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дано целое число, определить количество цифр в этом числе. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
1. Дано двузначное число. Найти разность и частное его цифр. 2. Дано целое число. Если оно является положительным то прибавить к нему 1. Емли нулевым то заменить его на 10. 3. Дано двузначное число. Вывести его левую цифру, потом правую. 4.
Ответы (1)
Дано целое число. Определить в этом числе количество цифр, сумму чисел, среднее арифметическое. (Pascal)
Ответы (1)
Дано целое трехзначное число. Определить есть ли среди его цифр одинаковые. Формат входных данных Входной файл содержит неотрицательное трехзначное целое число.
Ответы (1)