Задать вопрос
8 августа, 18:46

Дано целое число. Определить в этом числе количество цифр, сумму чисел, среднее арифметическое. (Pascal)

+3
Ответы (1)
  1. 8 августа, 20:55
    0
    program digits;

    var i, k, s, n, n1: integer;

    / / i - параметр цикла, k - количество цифр,

    / / s - сумма цифр, n - вводимое число, n1 - копия числа.

    begin

    writeln ('Введите число');

    readln (n);

    n1: = n;

    while n > 0 do / / определение количества цифр числа n

    begin

    n: = n div 10;

    k: = k + 1;

    end;

    writeln ('Количество цифр: ', k);

    s: = n1 mod 10; / / определение последней цифры

    for i: = 1 to k - 1 do / /определение остальных цифр и их суммы

    begin

    n1: = n1 div 10;

    s: = s + n1 mod 10;

    end;

    writeln ('Сумма цифр: ', s);

    writeln ('Среднее арифметическое цифр: ', s / k: 6:2)

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дано целое число. Определить в этом числе количество цифр, сумму чисел, среднее арифметическое. (Pascal) ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
1. Дано двузначное число. Найти разность и частное его цифр. 2. Дано целое число. Если оно является положительным то прибавить к нему 1. Емли нулевым то заменить его на 10. 3. Дано двузначное число. Вывести его левую цифру, потом правую. 4.
Ответы (1)
Дано натуральное число n. Определить: a) Количество цифр в этом числе; б) Сумму его цифр; в) Первую цифру числа n;
Ответы (1)
1) дано целое число N (больше 0). Найти сумму 1+1/2+1/3 ... 1/N (вещественное число). Входные данные: ввести целое числоN (1
Ответы (1)