Задать вопрос

Рассматривается четырёхугольник, у которого две стороны па - раллельны. На вход алгоритму подаются два числа - значения углов в градусах, прилежащих к одной из параллельных сторон. Алгоритм должен определить, к какому типу относится четырёхугольник, и выве - сти соответствующее сообщение. Типы четырёхугольников: обыкно - венная трапеция, равнобедренная трапеция, прямоугольная трапеция, прямоугольник,

+4
Ответы (1)
  1. 15 октября, 10:45
    0
    Для начала создания алгоритма задаем условия для определения, к какому типу относится четырехугольник:

    Var n, m:real;

    begin

    repeat

    writeln ('Ввести значения двух углов прилежащих к параллельной стороне в градусах');

    readln (n, m);

    until (n>0) and (m>0) and (n<180) and (m<180) and (m + (180-m) + n + (180-n) = 360);

    Далее задаем условия, по которым можно эти прямоугольники определить:

    if (n=m) and (m=90) then writeln ('Прямоугольник');

    else if (n=m) then writeln ('Равнобедренная трапеция');

    else if ((n=90) and (m90)) or ((m=90) and (n90)) then writeln ('Прямоугольная трапеция');

    else writeln ('Обыкновенная трапеция');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Рассматривается четырёхугольник, у которого две стороны па - раллельны. На вход алгоритму подаются два числа - значения углов в градусах, ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
13. На два входа черного ящика подаются цепочки из двоичных чисел 1 и 0. Если хотя бы на один вход подается 1, то на выходе образуется 1, в противном случае, на выходе будет 0.
Ответы (1)
Что такое алгоритм? Зачем люди составляют и исполняют алгоритм. Какими разными способами можно описать способ решения задач? Как называют наглядную модель процесса решения задач? Какой алгоритм можно назвать линейным?
Ответы (1)
Разработать алгоритм для ввода четырёх целых чисел и вычисление их среднего арифметического. Протестировать алгоритм на исходных данных: - 5,8,-1,9. Линейный алгоритм
Ответы (1)
Дана цепочка символов СТОП. Какая цепочка символов получится, если к данной цепочке применить описанный алгоритм дважды (т. е. применить алгоритм к данной цепочке, а затем к результату вновь применить алгоритм) ?
Ответы (1)
Составить алгоритм сложения двух целых чисел F и Q, вводимых с клавиатуры. Результат сложения записать в виде переменной W. По данному алгоритму написать программу в Паскале. алг сложение цел F, Q, W нач ввод F ввод Q W:=F+Q вывод W кон 2.
Ответы (1)