Войти
Задать вопрос
Александра Попова
Информатика
6 августа, 04:16
Найти сумму цифр целого положительного числа
+1
Ответы (
1
)
Таисия Парфенова
6 августа, 05:23
0
program xx1;
var s1, n1, k1:integer; / / описываем переменные целого типа
begin
writeln (' введите заданное число ');
read (n1); / / вводим число с клавиатуры
s1:=0; / / задаем начальное значение переменной суммы
while n1 > 0 do / / организуем цикл, пока в числе есть цифры
begin
k1:=n1 mod 10; / / получаем последнюю цифру заданного числа
s1:=s1 + k1; / / прибавляем ее к сумме
n1:=n1 div 10; / / выбрасываем цифру из числа
end;
/ / выводим ответ
writeln (' сумма цифр заданного числа = ', s1);
end.
Комментировать
Жалоба
Ссылка
Знаешь ответ на этот вопрос?
Отправить
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆
«Найти сумму цифр целого положительного числа ...»
по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Напишите программу на языке Паскаль для нахождение количества цифр в записи положительного целого числа x.
Ответы (1)
Оператор mob (a, b) - находит остаток отделения целого числа а на целое число b, например:mob (25,4) = 1. Оператор div (a, b) - находит целую часть от деления целого числа а на целое число b, например:div (25,4) = 6.
Ответы (1)
Написать программу в паскаль "найти сумму цифр сколь угодно значного целого числа". Использовать string
Ответы (1)
Вычислить сумму цифр заданного целого трехзначного числа. в паскале
Ответы (1)
Нужен ответ
1. Назовите город, правитель которого начал Троянскую войну. В каком веке это произошло? 2. Сформулируйте историческую причину начала Троянской войны? 3. Сформулируйте мифологическую причину начало Троянской войны?
Нет ответа
Используя свойство 3 степеней, запишите в виде степениа) (2^2) ^3 б) (3^4) ^2 в) (3^7) ^2 г) (5^3) ^4 д) (10^3) ^5 е) (7^2) ^4
Нет ответа
Расположите числа 5,28; - 1,634; - 1,34; - 1, (3); 2,3 (4) и 2, (34) в порядке убывания
Нет ответа
сравнить природные условия финикии древнего египта и индии
Нет ответа
Расстояние между двумя пунктами 40 км. Из одного из них в другой одновременно въезжают автобус и велосипедист. Скорость автобуса 50 км в час, велосипедиста 10 км в час.
Нет ответа
Главная
»
Информатика
» Найти сумму цифр целого положительного числа
Войти
Регистрация
Забыл пароль