Задать вопрос

Вычислить сумму цифр заданного целого трехзначного числа. в паскале

+3
Ответы (1)
  1. 1 июня, 17:15
    0
    program zz1;

    var a, b, c, V:integer;

    begin

    read (V); / /вводим исходное трехзначное число

    a:=V mod 10; / /получаем первую цифру числа

    b: = (V mod 100) div 10; / /получаем вторую цифру числа

    c:=V div 100; / / получаем третью цифру числа

    write ('сумма цифр заданного трехзначного числа - ', a+b+c); / /выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Вычислить сумму цифр заданного целого трехзначного числа. в паскале ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Дано трехзначное число. Напишите программу, которая опеределяет Есть ли среди цифр заданного целого трехзначного числа одинаковые
Ответы (1)
Составте программу, вычисления суммы цифр трёхзначного числа а. Значение а введите с клавиатуры Пример ввода: 375 Пример вывода: Сумма цифр числа 375 равна 15 2) Составте программу, которая получает 'перевёртыш' трёхзначного числа а.
Ответы (1)
Автомат получает на вход четырёхзначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам. 1. Вычисляются два числа - сумма четных цифр и сумма нечетных цифр заданного числа. 2.
Ответы (1)
Написать программу в Паскале Найти все натуральные числа, не превосходящие заданного n, которые делятся на каждую из своих цифр.
Ответы (1)