Задать вопрос

в двух файлах записано по 10 чисел, создать третий файл, в котором чередуются числа первых двух файла. Написать в программе PascalABC

+2
Ответы (1)
  1. 15 марта, 02:01
    0
    program f1_f2_f3;

    var

    f1, f2, f3: text;

    a, b: array [1 ... 10] of integer;

    begin

    AssignFile (f1, 'e:/pascal/n1. txt'); / /указать реальные полные имена файлов

    AssignFile (f2, 'e:/pascal/n2. txt');

    AssignFile (f3, 'e:/pascal/n3. txt');

    Reset (f1);

    for k: integer: = 1 to 10 do Read (f1, a[k]);

    CloseFile (f1);

    Reset (f2);

    for k:integer:=1 to 10 do Read (f2, b[k]);

    CloseFile (f2);

    rewrite (f3);

    for k: integer: = 1 to 10 do

    if k = 1 then write (f3, a[k], ' ', b[k]) else write (f3, ' ', a[k], ' ', b[k]);

    close (f3)

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «в двух файлах записано по 10 чисел, создать третий файл, в котором чередуются числа первых двух файла. Написать в программе PascalABC ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
У нас есть. bat файл. Если прописать: echo [Команда]>[Место сохранения]/Имя файла echo [Команда]>[Место сохранения]/Имя файла Имя файла одинаковое в двух случаях, но при запуске этого файла, создается бат файл и эти две (Или больше) команды
Ответы (1)
1. Файл размером 4 Мбайт передаётся через некоторое соединение за 100 секунд. Определите размер файла (в Кбайтах), который можно передать через это же соединение за 75 секунд. 2.
Ответы (1)
Установите соответствие между типами файлов и расширениями файлов. Текстовый файл Графический файл Web-страница Звуковой файл Видеофайл Системный файл Исполняемый файл txt bmp htm doc jpg mp3 html gif midi mpeg sys exe avi com
Ответы (1)
Дан файл из чисел. Создать второй файл из чисел первого файла, у которых сумма цифр находится в пределе от 12 до 34. Pascal
Ответы (1)
Имя входного файла:E. in имя выходного файла E. out Дается ... Имя входного файла:E. in имя выходного файла E. out Дается последовательность из N чисел. найдите максимальное произ. среди всех пар этих чисел.
Ответы (1)