Задать вопрос

Составьте на Паскале программу определения минимума из трёх чисел с использованием логических операций. Программа должна иметь дружественный интерфейс.

+1
Ответы (1)
  1. 21 марта, 14:06
    0
    program zz1;

    var a, b, c, min:integer; / /задаем переменные

    begin

    write ('введите первое число '); / /вводим с клавиатуры первое число

    read (a);

    write ('введите второе число '); //вводим с клавиатуры второе число

    read (b);

    write ('введите третье число '); //вводим с клавиатуры третье число

    read (c);

    min:=1000000; / /задаем начальное значение для минимума

    if (a < b) and (a < c) then min:=a; / /проверяем, если первое число наименьшее, то записываем его в min

    if (b < c) and (b < a) then min:=b; //проверяем, если второе число наименьшее, то записываем его в min

    if (c < b) and (c < a) then min:=c; //проверяем, если третье число наименьшее, то записываем его в min

    write ('минимальное среди трех заданных чисел = ', min); / /выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте на Паскале программу определения минимума из трёх чисел с использованием логических операций. Программа должна иметь ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Составить на Паскале программу определения минимума из трёх чисел без использования логических операций. Программа должна иметь дружественный интерфейс (ввод данных осуществляться в режиме диалога).
Ответы (1)
Треугольник задан длинами сторон А, В, С. Написать программу, определяющую, существует ли данный треугольник. Для решения этой задачи использовать сложные логические условия. Программа должна иметь дружественный интерфейс.
Ответы (1)
Составить на Паскале программу, которая по введённому номеру месяца выводит название времени года. При написании программы использовать логические операции.
Ответы (1)
Что обозначает понятие "дружественный интерфейс"?
Ответы (1)
Установите соответствие: 1) базовое системное ПО а) операционная система 2) утилиты б) программа диагностики дисков в) антивирусная программа г) операционная оболочка д) программа архивации данных e) программа обслуживания сети
Ответы (1)