Задать вопрос

Составьте список студентов spisok (10 записей), включающий Фамилию и 5 оценок. Напишите программу, удаляющую из списка тех, кто имеет хотя бы одну двойку. Массив и результат работы программы вывести на экран.

+3
Ответы (1)
  1. 7 сентября, 10:09
    0
    var

    ars: array[1 ... 10]of string;

    i, n, j: integer;

    begin

    n : = 10;

    for i : = 1 to 10 do

    begin

    readln (ars[i]);

    end;

    for i : = n downto 1 do

    if ((ars[i][length (ars[i]) ] = '2') or (ars[i][length (ars[i]) - 8] = '2') or

    (ars[i][length (ars[i]) - 4] = '2') or (ars[i][length (ars[i]) - 6] = '2') or

    (ars[i][length (ars[i]) - 2] = '2'))

    then

    begin

    for j : = i to n do

    ars[i] : = ars[i + 1];

    dec (n);

    end;

    writeln;

    for i : = 1 to n do

    writeln (ars[i]);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте список студентов spisok (10 записей), включающий Фамилию и 5 оценок. Напишите программу, удаляющую из списка тех, кто имеет хотя ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
1) Вывести массив A (N). Вывести на печать данные о числе нулевых элементов массива и их номера. Если таковых нет, вывести на печать сообщение об этом 2) Вывести массив А (N, N). Разделить все его элементы на минимальный элемент главной диагонали.
Ответы (1)
Дан массив из 10 элементов заполнить с клавиатуры: 1) вывести массив 2) вывести массив на экран 3) поменять местами 6 и 9 элемент массива 4) найти max элементов массива
Ответы (1)