Задать вопрос

1) Вывести массив A (N). Вывести на печать данные о числе нулевых элементов массива и их номера. Если таковых нет, вывести на печать сообщение об этом 2) Вывести массив А (N, N). Разделить все его элементы на минимальный элемент главной диагонали. Вывести исходный и преобразованный массивы в виде матриц.

+3
Ответы (1)
  1. 5 сентября, 13:03
    0
    Задача 1.

    var

    number, count: integer;

    arr: array[1 ... 10] of integer;

    begin

    for number : = 1 to 10 do

    begin

    arr[number] : = random (10);

    write (arr[number]:5);

    end;

    writeln ();

    writeln ('Ненулевые элементы массива:');

    for number : = 1 to 10 do

    begin

    if not (arr[number] = 0) then

    begin

    count:=count+1;

    writeln ('элемент ', arr[number]:3, ' на позиции ', number:3);

    end

    end;

    if count=0 then

    write (' ненулевых элементов нет');

    end.

    Задача 2.

    var

    number, col:integer;

    count, min_el: real;

    arr: array[1 ... 5,1 ... 5] of real;

    begin

    writeln ('Исходный массив:');

    for number: = 1 to 5 do

    begin

    for col: = 1 to 5 do

    begin

    arr[number, col] : = random (10) + 2;

    write (arr[number, col]:5);

    end;

    writeln ();

    end;

    min_el:=arr[1,1];

    for number: = 1 to 5 do

    for col:=1 to 5 do

    if col=number then

    if arr[number, col]
    min_el:=arr[number, col];

    writeln ('Минимальный элемент главной диагонали: ', min_el);

    writeln ('Преобразованный массив:');

    for number: = 1 to 5 do

    begin

    for col: = 1 to 5 do

    begin

    arr[number, col] : = arr[number, col]/min_el;

    write (arr[number, col]:5:1);

    end;

    writeln ();

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1) Вывести массив A (N). Вывести на печать данные о числе нулевых элементов массива и их номера. Если таковых нет, вывести на печать ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Дан массив целых чисел. Поменять местами первый максимальный (если таковых несколько) и последний минимальный (если таковых несколько) по значению элементы массива. Число элементов в массиве не более 10-ти Pascal
Ответы (1)
В массиве все положительные элементы увеличить в 2 раза, а все отрицательные заменить на 7. Вывести на экран исходный и преобразованный массивы.
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными индексами. выведите на экран исходный массив и полученное среднее арифметическое. 2.
Ответы (1)
С+ + Напишите программу, которая выводит номера элементов массива, равных заданному значению X. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)