Задать вопрос

Найти сумму всех натуральных чисел, четных, кратных 7 и меньших 100.

+3
Ответы (1)
  1. 6 февраля, 18:40
    0
    program zz1;

    var b, i:integer; / / задаем переменные целого типа

    begin

    i:=1; / / задаем начальное значение для параметра цикла

    while i < 100 do / / организуем цикл, пока параметр цикла не достигнет ста

    begin

    if (i mod 2 = 0) and (i mod 7 = 0) then b:=b + i; / / проверяем, если число четное и кратное семи, то добавляем число к сумме

    i:=i + 1; / / увеличиваем параметр цикла на единицу

    end;

    write (' сумма всех натуральных чисел, четных, кратных 7 и меньших 100 = ', b); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Найти сумму всех натуральных чисел, четных, кратных 7 и меньших 100. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Найти произведение всех натуральных чисел, кратных 3 и меньших 13. Обратите внимание, что начальное значение Р=1. 2. Найти количество натуральных чисел, нечет
Ответы (1)
Напишите программу, которая в последовательности из 10 натуральных чисел определяет сумму чисел определяет сумму чисел, кратных 5. в последовательности всегда имеется число, кратное 5 программа должна вывести одно число сумму чисел кратных 5
Ответы (1)
Напишите программу на языке паскаль, которая вычесляет сумму: а) первых n натуральных чисел; б) квадратов первых n натуральных чисел; в) всех чётных чисел в диапазоне от 1 до n; г) всех двузначных чисел.
Ответы (1)
1. Напишите программу, которая находит количество чисел, кратных 3, но не кратных 6, в последовательности целых чисел.
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов2) Дан массив целых чисел.
Ответы (1)