Задать вопрос
8 октября, 10:47

1. Выведите на экран значение логического выражения, которое принимает значение true, если К является двухзначным числом, кратным пяти и false - в противном случае.

+5
Ответы (1)
  1. 8 октября, 14:14
    0
    program k5_2;

    var k: integer;

    m: boolean;

    begin

    k : = 1;

    while k0 do

    begin

    write ('Введите число k = ');

    readln (k);

    if ((k > 9) and (k < 100) and (k mod 5 = 0)) then m : = true else m : = false;

    writeln (m)

    end

    end.

    В программе проверяется условие: число должно быть больше 9 и меньше 100 (то есть двузначным), а также кратным числу 5 для того, чтобы логическая переменная m приняла значение truе. Если хотя одна часть условия не выполняется, то m = false.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1. Выведите на экран значение логического выражения, которое принимает значение true, если К является двухзначным числом, кратным пяти и ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Составьте программу, входящую true, если высказывание является истинным, и false в противном случае: а) сумма цифр трехзначного числа х является четным числом; б) треугольник со сторонами a, b, c является разносторонним
Ответы (1)
Составьте программу в Паскаль, вводящую true, если высказывание является истинным, и false в противном случае. а) Треугольник со сторонами a, b, с являются равносторонним. б) целое число N является чётным двузначным числом
Ответы (1)
Составить программу, печатающую значение true, если указанное высказывание является истинным, и false в противном случае: число с является средним геометрическим чисел а и b.
Ответы (1)
Составить линейную программу, печатающую значение true, если указанное высказывание является истинным, и false - в противном случае: трегольник со сторонами a, b, c являеться равнобедренным. (решить через файл)
Ответы (1)
Составьте программу вводящую true если высказывания являются истинными и false в противном случае треугольник со сторонами a b c является равносторонним
Ответы (1)