Задать вопрос

Вычислите периметр и площадь прямоугольного треугольника если стороны треугольника вводятся с клавиатуры (a, b, c; a, d-катеты)

+3
Ответы (1)
  1. 5 мая, 16:29
    0
    program zz1;

    var a, b, c, s, p:real;

    begin

    writeln ('Введите сторону треугольника а'); / /вводим первый катет

    read (a);

    writeln ('Введите сторону треугольника b'); / /вводим второй катет

    read (b);

    writeln ('Введите сторону треугольника c'); / /вводим гипотенузу

    read (c);

    p:=a+b+c; / /находим периметр

    writeln ('Периметр треугольника = ', p); / / выводим ответ

    p:=p/2; / /получаем полу периметр

    s:=sqrt (p * (p-a) * (p-b) * (p-c)); / /вычисляем площадь по формуле Герона

    write ('Площадь треугольника = ', s); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Вычислите периметр и площадь прямоугольного треугольника если стороны треугольника вводятся с клавиатуры (a, b, c; a, d-катеты) ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)
1) Ввести с клавиатуры целое число. Определить четное оно, или нечетное. 2) Решить следующие задачи: Является ли треугольник с длинами сторон a, b, c : * прямоугольным; * равнобедренным; * равносторонним. Стороны вводятся с клавиатуры.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1. Найти сумму элементов массива принадлежащих промежутку от C до D (C и D вводятся с клавиатуры). 2. Определить есть ли в данном массиве положительные элементы кратные k (k вводится с клавиатуры). Паскаль
Ответы (1)
Написать программу: c клавиатуры последовательно вводятся числа, пока не введут 0. Вывести на экран количество положительных и отрицательных чисел, введенных с клавиатуры.
Ответы (1)