Задать вопрос

Написать программу: c клавиатуры последовательно вводятся числа, пока не введут 0. Вывести на экран количество положительных и отрицательных чисел, введенных с клавиатуры.

+2
Ответы (1)
  1. 11 ноября, 05:46
    0
    program zz1;

    var x, y, k:integer; / / задаем переменные целого типа

    begin

    x:=1;

    while x 0 do / / организуем цикл, в котором будем вводить числа последовательности, пока не введем ноль

    begin

    read (x);

    if (x >0) then y:=y + 1; / / проверяем, если число последовательности положительное, то считаем его

    if (x <0) then k:=k + 1; / / проверяем, если число последовательности отрицательное, то считаем его

    end;

    write (' количество положительных чисел = ', y, ' количество отрицательных чисел = ', k); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу: c клавиатуры последовательно вводятся числа, пока не введут 0. Вывести на экран количество положительных и ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)
Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные Три целых числа вводятся в одной строке через пробелы.
Ответы (1)
Написать программу в которой вводятся целые числа и подсчёт количества введённых положительных и отрицательных чисел
Ответы (1)