Задать вопрос

1) Составить программу определяющую правильно ли введено число в двенадцатиперстной системе счисления. 2) Дан массив А (n, n). Найти произведение четных элементов массива.

+5
Ответы (1)
  1. 18 апреля, 01:45
    0
    1) program zz1;

    var i, p:integer; / / задаем переменные целого типа

    s:string;

    begin

    write (' введите число ');

    read (s);

    for i:=1 to length (s) do

    if (s[i]'0') and (s[i]'1') and (s[i]'2') and (s[i]'3') and (s[i]'4') and

    (s[i]'5') and (s[i]'6') and (s[i]'7') and (s[i]'8') and (s[i]'9') and

    (s[i]'A') and (s[i]'B') then begin p:=1; break; end;

    if p = 1 then write (' число записано неправильно ') else write (' число записано правильно ');

    END.

    2) program zz1;

    const n = 4; / / задаем количество элементов в массиве

    var i, j, p:integer; / / задаем переменные целого типа

    b:array [1 ... n, 1 ... n] of integer;

    begin

    for i:=1 to n do

    for j:=1 to n do / / получаем числа и записываем их в массив

    b[i, j]:=random (10);

    for i:=1 to n do / / выводим полученный массив на экран

    begin

    for j:=1 to n do

    write (b[i, j]:4);

    writeln;

    end;

    p:=1;

    for i:=1 to n do

    begin

    for j:=1 to n do

    if (b[i, j] mod 2 = 0) and (b[i, j]0) then p:=p * b[i, j]

    end;

    writeln (' произведение четных элементов = ', p); / /выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1) Составить программу определяющую правильно ли введено число в двенадцатиперстной системе счисления. 2) Дан массив А (n, n). Найти ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Какие целые числа за числами: а) 101011 - в двоичной системе счисления б) 7777 - в восьмеричной системе счисления в) CDEF - в шестнадццатеричной системе счисления 2.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1. Дан одномерный массив из N элементов. Заменить в нем значение макс и мин элемента на сумму всех элементов массива 2. Дан одномерный массив из Н элементов. Найти среднее арифметическое положительных четных элементов данного массива
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика целых случайных чисел. Найдите сумму четных элементов массива. Выведите на экран исходный массив и полученную сумму. 2. Дан массив В (n). Определите произведение элементов, кратных 3.
Ответы (1)
Дан целочисленный массив из 2000 элементов. Если сумма всех элементов массива чётная, нужно вывести количество нечётных (по значению) элементов массива, если нечётная - количество чётных.
Ответы (1)