Задать вопрос

Найдите количество троек натуральных чисел X, Y, Z на интервале [10; 5000], которые удовлетворяют условиям: Х

+4
Ответы (1)
  1. 9 августа, 11:10
    0
    program zz1; / / в связи с тем, что в решении для перебора используется вложенные циклы, программа будет работать долго

    var x, y, z:integer; / / задаем переменные

    begin

    for x:=10 to 5000 do / / организуем три вложенных в друг друга цикла для перебора всех чисел от 10 до 5000

    for y:=10 to 5000 do

    for z:=10 to 5000 do

    if (x < y) and (z mod 10 = 5) and (x*x+y*y=z) / / проверяем заданные условия

    then writeln ('x=', x,' y=', y,' z=', z); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Найдите количество троек натуральных чисел X, Y, Z на интервале [10; 5000], которые удовлетворяют условиям: Х ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Найти сумму нечетных чисел на интервале [-30; 40]. 2) Найти кол-во чисел на интервале [-50; 120], которые кратны 9. 3) Найти произведение чисел кратных 11 на интервале [-10; 20]. 4) Последовательно вводятся N чисел. Найти их произведение.
Ответы (1)
1. В массиве B[5,6], значения элементов находятся в интервале [-25,30]. Подсчитать количество элементов, значение которых кратно 4. 2. В массиве C[6,10], значения элементов находятся в интервале [10,30], найти сумму элементов в 1 строке. 3.
Ответы (1)
Напишите программу, которая подсчитывает количество двузначных чисел в заданной последовательности натуральных чисел. Программа получает на вход количество чисел в последовательности, а затем сами числа. Количество чисел не превышает 1000.
Ответы (1)
С клавиатуры вводятся числа от 1 до 9 до тех пор, пока не будет введен 0. Посчитайте количество единиц в этой последовательности, количество двоек, количество троек и так далее (программа должна вывести ровно 9 чисел).
Ответы (1)
найти количество всех натуральных чисел которые удовлетворяют условия 22x+14y=8456
Ответы (1)