Задать вопрос

1) Найти сумму нечетных чисел на интервале [-30; 40]. 2) Найти кол-во чисел на интервале [-50; 120], которые кратны 9. 3) Найти произведение чисел кратных 11 на интервале [-10; 20]. 4) Последовательно вводятся N чисел. Найти их произведение.

+4
Ответы (1)
  1. 17 января, 02:32
    0
    1) program zz1;

    var i, s:integer; / / задаем переменные целого типа

    begin

    for i:=-30 to 40 do / / организуем цикл, в котором переберем все числа

    if i mod 2 = 1 then s:=s + i;

    writeln (' сумма нечетных чисел от - 30 до 40 = ', s); / / выводим ответ

    end.

    2) program zz1;

    var i, s:integer; / / задаем переменные целого типа

    begin

    for i:=-50 to 120 do / / организуем цикл, в котором переберем все числа

    if i mod 9 = 0 then s:=s + 1;

    writeln (' количество чисел кратных 9 = ', s); / / выводим ответ

    end.

    3) program zz1;

    var i, s:integer; / / задаем переменные целого типа

    begin

    s:=1;

    for i:=-10 to 20 do / / организуем цикл, в котором переберем все числа

    if (i0) and (i mod 11 = 0) then s:=s * i;

    writeln (' произведение чисел кратных 11 = ', s); / / выводим ответ

    end.

    4. program zz1;

    var n, i, p, a:integer; / / вводим переменную целого типа

    begin

    write (' введите число n'); / / вводим с клавиатуры число

    read (n);

    p:=1;

    for i:=1 to n do / / организуем цикл

    begin

    read (a);

    p:=p * a;

    end;

    writeln (' произведение чисел = ', p); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1) Найти сумму нечетных чисел на интервале [-30; 40]. 2) Найти кол-во чисел на интервале [-50; 120], которые кратны 9. 3) Найти ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. В массиве B[5,6], значения элементов находятся в интервале [-25,30]. Подсчитать количество элементов, значение которых кратно 4. 2. В массиве C[6,10], значения элементов находятся в интервале [10,30], найти сумму элементов в 1 строке. 3.
Ответы (1)
С клавиатуры вводятся последовательно из k целых чисел вычислить произведение нечетных членов последовательности
Ответы (1)
С клавиатуры последовательно вводятся 15 разных целых чисел, которые размещаются в массиве. Напишите программу, которая выводит на экран количество элементов массива кратных 5 и минимальное среди подходящих под это условие.
Ответы (1)
В одну и ту же числовую переменную последовательно вводятся целые числа. Количесвто вводимых чисел заранее известно (0 - конец ввода). Определить количество чисел не кратных 5.
Ответы (1)
1. Напишите программу, которая находит количество чисел, кратных 3, но не кратных 6, в последовательности целых чисел.
Ответы (1)