Задать вопрос
27 августа, 12:03

Найти сумму "n" чисел последовательности: 2,7,12,17, ...

+5
Ответы (1)
  1. 27 августа, 13:50
    0
    program zz1;

    var k, b, i, n, c:integer; / / задаем переменные целого типа

    begin

    write (' введите n '); / / вводим с клавиатуры число

    read (n);

    i:=2; / / записываем в переменную первое число последовательности

    c:=0;

    while c < n do / / организуем цикл, пока параметр цикла не достигнет n

    begin

    b:=b + i; / / добавляем число к сумме

    c:=c + 1; / / увеличиваем параметр цикла на единицу

    i:=i + 5; / / получаем следующее число последовательности

    end;

    write (' сумма "n" чисел последовательности = ', b); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Найти сумму "n" чисел последовательности: 2,7,12,17, ... ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напишите программу, которая в последовательности из 10 натуральных чисел определяет сумму чисел определяет сумму чисел, кратных 5. в последовательности всегда имеется число, кратное 5 программа должна вывести одно число сумму чисел кратных 5
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3.
Ответы (1)
Напишите программу, которая подсчитывает количество двузначных чисел в заданной последовательности натуральных чисел. Программа получает на вход количество чисел в последовательности, а затем сами числа. Количество чисел не превышает 1000.
Ответы (1)
Дана непустая последовательность чисел оканчивающаяся нулем. Найти: а) сумму всех чисел последовательности, б) кол-во всех чисел последовательности. решить через Pascal ABC через repeat, for или while
Ответы (1)
1. напишите программу, которая для последовательности натуральных чисел определяет их сумму. Программа получает на вход количество чисел в последовательности и сами числа 2. Измените программу так, чтобы определялось произведение чисел. 3.
Ответы (1)