Задать вопрос

1) записать условие оператор в котором значение переменной вычисляется по формуле: а+в, если а-нечетное и а*в, если а - четное 2) Вычислить значение функции Функция: x^{2}+5, при х>3 х-8, при х< или = 3 3) Составить алгоритм нахождения большего их 3-х чисел

+2
Ответы (1)
  1. 22 марта, 08:09
    0
    1) program zz1;

    var a, b, n:integer; / / вводим переменные целого типа

    begin

    write (' введите a '); / / вводим с клавиатуры число a

    read (a);

    write (' введите b '); / / вводим с клавиатуры число b

    read (b);

    if a mod 2 = 0 / / проверяем условие

    then n:=a + b

    else n:=a * b;

    write (' значение переменной = ', n); / / выводим ответ

    end.

    2) program zz1;

    var x, y:integer; / / вводим переменные целого типа

    begin

    write (' введите x '); / / вводим с клавиатуры число x

    read (x);

    if (x > 3) then y:=x*x+5

    else y:=x-8;

    write (' значение функции = ', y); / / выводим ответ

    end.

    3) program zz1;

    var a, b, c, n:integer; / / вводим переменные целого типа

    begin

    write (' введите a '); / / вводим с клавиатуры число a

    read (a);

    write (' введите b '); / / вводим с клавиатуры число b

    read (b);

    write (' введите c '); / / вводим с клавиатуры число с

    read (c);

    if (a > b) and (a > c) then n:=a;

    if (b > a) and (b > c) then n:=b;

    if (c > b) and (c > a) then n:=c;

    write (' большее из трех = ', n); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1) записать условие оператор в котором значение переменной вычисляется по формуле: а+в, если а-нечетное и а*в, если а - четное 2) Вычислить ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Запишите на алгоритмическом языке алгоритм, в результате которого переменной а будет присвоено значение переменной Ь, переменной b - значение переменной с, а переменной с - значение переменной а. Используйте не более одной промежуточной переменной.
Ответы (1)
Составить алгоритм нахождения НОД трех натуральных чисел, используя вспомогательный алгоритм нахождения НОД двух чисел.
Ответы (1)
Напишите программу в которой значение вычисляется по формуле a+b, если а - нечетное число и а*b, если а - четное число (if a mod не равно 0)
Ответы (1)
1. какие команды присваивания составлены правильно? a) A: = В б) А=В в) А=B+1 г) А+1:=А 2. Сколько промежуточных переменных потребуется для того, чтобы переменной А было присвоено значение переменной В, переменной В - значение переменной С, а
Ответы (1)
1. Составить программу для нахождения площади трапеции. 2. Составить программу для нахождения квадрата суммы двух чисел (по формулам сокращённого умножения). 3.
Ответы (1)