Задать вопрос

Дано линейный массив. Найти количество тех элементов, которые по величине не принадлежат числовому промежутку [x, y].

+2
Ответы (1)
  1. 22 сентября, 08:05
    0
    Вот исходный код решения данной задачи

    #include

    using namespace std;

    int main ()

    {

    int A[100000];

    int n, x, y, count = 0;

    cin >> n >> x >> y;

    for (int i = 0; i < n; i++)

    {

    cin >> A[i];

    if (A[i] > y || A[i] < x)

    {

    count++;

    }

    }

    cout << count;

    }
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дано линейный массив. Найти количество тех элементов, которые по величине не принадлежат числовому промежутку [x, y]. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1) задан массив из N элементов. вычислить среднее арифметическое тех элементов, которые кратны 3. 2) Задан массив из N элементов. Сформировать новый массив из элементов, кратных 7.
Ответы (1)
Решите одно из предложенных, умоляю дан массив А5 найти сумму и количество положительных элементов дан массив А5 определить количество отрицательных элементов дан массив А6 определить количество положительных элементов
Ответы (1)
1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива. 2.
Ответы (1)
1. В массиве B[5,6], значения элементов находятся в интервале [-25,30]. Подсчитать количество элементов, значение которых кратно 4. 2. В массиве C[6,10], значения элементов находятся в интервале [10,30], найти сумму элементов в 1 строке. 3.
Ответы (1)