Задать вопрос

1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива. 2. Создать массив A из 10 элементов, заполненный случайным образом числами принадлежащих промежутку (0; 20). Вывести полученный массив на экран. Вычислить количество элементов массива, значения которых не превышают среднее арифметическое значений его элементов.

+2
Ответы (1)
  1. 1 июня, 15:30
    0
    program zz1;

    const n = 10; / /задаем количество элементов в массиве

    var i, max1, k, s, p:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / записываем в массив числа случайным образом

    m[i]:=random (101);

    for i:=1 to n do / /выводим массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    max1:=0;

    for i:=1 to n do / / находим максимальный элемент

    if m[i]>max1 then begin max1:=m[i]; k:=i; end;

    writeln (' максимальный элемент = ', max1); / / выводим ответ

    for i:=1 to n do / / записываем в массив числа случайным образом

    m[i]:=random (21);

    for i:=1 to n do / /выводим массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    for i:=1 to n do

    s:=s+m[i];

    for i:=1 to n do

    if m[i]
    writeln (' количество найденных элементов = ', p); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Создать массив а из десяти целых чисел, принадлежащих промежутку [0; 20). вывести полученный массив на экран. вычислить количество элементов массива, значения которых превышают средне арифметическое значений его элементов
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1. Найти количество натуральных чисел, не превышающих 100 и кратных 5.2. Создать массив А из 10 элементов, принадлежащих промежутку (0; 25). Вывести полученный массив на экран. Подсчитать количество элементов, больших А [1]. Все с помощью Паскаля
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными индексами. выведите на экран исходный массив и полученное среднее арифметическое. 2.
Ответы (1)