Задать вопрос

Написать программу вычисления суммы всех двузначных чисел.

+4
Ответы (1)
  1. 14 февраля, 05:49
    0
    program zz1;

    var r, i:integer; / / задаем переменные целого типа

    begin

    for i:=10 to 99 do / / организуем цикл, в котором переберем все двухзначные числа от 10 до 99

    r:=r + i; / / вычисляем сумму чисел от 10 до 99 по формуле

    write (' сумма всех двухзначных чисел от ', 10,' до ', 99,' = ', r); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу вычисления суммы всех двузначных чисел. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Дана последовательность чисел, вводимых с клавиатуры и оканчивающаяся нулем. Составьте программу вычисления: a. суммы всех чисел последовательности; b. среднего арифметического всех чисел последовательности: c.
Ответы (1)
Напишите программу, которая подсчитывает количество двузначных чисел в заданной последовательности натуральных чисел. Программа получает на вход количество чисел в последовательности, а затем сами числа. Количество чисел не превышает 1000.
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
Напишите программу на языке паскаль, которая вычесляет сумму: а) первых n натуральных чисел; б) квадратов первых n натуральных чисел; в) всех чётных чисел в диапазоне от 1 до n; г) всех двузначных чисел.
Ответы (1)