Задать вопрос

Дана последовательность чисел, вводимых с клавиатуры и оканчивающаяся нулем. Составьте программу вычисления: a. суммы всех чисел последовательности; b. среднего арифметического всех чисел последовательности: c. суммы только отрицательных и суммы только положительных чисел последовательности.

+1
Ответы (1)
  1. 23 мая, 15:34
    0
    program zz1;

    var i, k, n, k1, k2:integer; / / задаем переменные целого типа

    m:array [1 ... 10000] of integer;

    begin

    read (m[1]); i:=1;

    while m[i]0 do / / вводим числа последовательности с клавиатуры до тех пор, пока не введем ноль, записываем их в массив

    begin

    i:=i+1;

    read (m[i]);

    end;

    n:=i;

    for i:=1 to n do / / организуем цикл, в котором переберем все числа последовательности

    begin

    k:=k + m[i]; / / получаем сумму всех чисел последовательности

    if m[i] > 0 then k1:=k1 + m[i]; / / получаем сумму положительных чисел

    if m[i] < 0 then k2:=k2 + m[i]; / / получаем сумму отрицательных чисел

    end;

    writeln (' сумма чисел последовательности = ', k); / /выводим ответ

    writeln (' среднее арифметическое чисел последовательности = ', k/n:5:2);

    writeln (' сумма положительных чисел последовательности = ', k1);

    write (' сумма отрицательных чисел последовательности = ', k2);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дана последовательность чисел, вводимых с клавиатуры и оканчивающаяся нулем. Составьте программу вычисления: a. суммы всех чисел ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дана непустая последовательность целых чисел, оканчивающаяся нулем (0 является признаком окончания последовательности и в последовательность не входит). Найти и напечатать: 1. Сумму всех чисел, больших Х (значение Х вводится с клавиатуры).
Ответы (1)
Дана непустая последовательность чисел оканчивающаяся нулем. Найти: а) сумму всех чисел последовательности, б) кол-во всех чисел последовательности. решить через Pascal ABC через repeat, for или while
Ответы (1)
Дана непустая последовательность положительных целых чисел a1, a2, ... оканчивающаяся нулем. Получить a1, a1*a2, a1*a2*a3 ... 0 Решить, используя оператор until repeat либо while (паскаль)
Ответы (1)
Вводится последовательность целых чисел, оканчивающаяся нулем. Число 0 в последовательность не входит. Выведите элементы последовательности в обратном порядке. Для хранения данных используйте стек.
Ответы (1)
1 Написать процедуру вычисления среднего арифметического двух чисел. Числа и результат передаются в качестве параметров, в каком из двух введенных с клавиатуры целых чисел произведение цифр больше.
Ответы (1)