Задать вопрос

Дан целочисленный массив из 20 элементов. Элементы массива могут быть целыми числами от - 1000 до 1000. Найдите минимальный элемент среди положительных, делящихся на 3 и нечетных

+1
Ответы (1)
  1. 29 июля, 08:39
    0
    program zz1;

    const n = 20; / /задаем количество элементов в массиве

    var i, min, k:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / записываем в массив числа случайным образом

    m[i]:=random (2001) - 1000;

    for i:=1 to n do / /выводим массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    min:=100000;

    for i:=1 to n do / / находим минимальный элемент

    if ((m[i] mod 2 = 1) or (m[i] mod 2 = - 1)) and (m[i] mod 3 = 0) and (m[i] > 0) then if m[i] < min then min:=m[i];

    if min = 100000 then writeln (' таких чисел нет ') / / выводим ответ

    else write (' найденный минимальный элемент = ', min);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дан целочисленный массив из 20 элементов. Элементы массива могут быть целыми числами от - 1000 до 1000. Найдите минимальный элемент среди ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
Дан целочисленный массив из 2000 элементов. Если сумма всех элементов массива чётная, нужно вывести количество нечётных (по значению) элементов массива, если нечётная - количество чётных.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Заполнить массив из 15 элементов целыми случайными числами из диапазона от 0 до 40. Вывести массив на экран и найти сумму элементов массива, минимальный элемент массива и количество чисел больше 10
Ответы (1)